Commit 8cca1bda authored by Lukáš Krupčík's avatar Lukáš Krupčík
Browse files

new file: g/GDAL/GDAL-3.2.1-foss-2020b.eb

	new file:   o/OpenFOAM/OpenFOAM-v2106-foss-2020b.eb
	new file:   p/ParaView/ParaView-5.9.1-foss-2020b-mpi.eb
	deleted:    o/OpenFOAM/OpenFOAM-v2106-foss-2021a.eb
parent c72c7d64
Pipeline #21679 passed with stage
in 6 seconds
# IT4Innovations
# LK 2021
easyblock = 'ConfigureMake'
name = 'GDAL'
version = '3.2.1'
homepage = 'https://www.gdal.org'
description = """GDAL is a translator library for raster geospatial data formats that is released under an X/MIT style
Open Source license by the Open Source Geospatial Foundation. As a library, it presents a single abstract data model
to the calling application for all supported formats. It also comes with a variety of useful commandline utilities for
data translation and processing."""
toolchain = {'name': 'foss', 'version': '2020b'}
toolchainopts = {'usempi': True}
source_urls = ['https://download.osgeo.org/gdal/%(version)s/']
sources = [SOURCELOWER_TAR_XZ]
patches = ['GDAL-3.0.0_fix-python-CC-CXX.patch']
checksums = [
'6c588b58fcb63ff3f288eb9f02d76791c0955ba9210d98c3abd879c770ae28ea', # gdal-3.2.1.tar.xz
'223a0ed1afb245527d546bb19e4f80c00f768516ab106d82e53cf36b5a1a2381', # GDAL-3.0.0_fix-python-CC-CXX.patch
]
builddependencies = [
('pkg-config', '0.29.2'),
]
dependencies = [
('Python', '3.8.6'),
('netCDF', '4.7.4'),
('expat', '2.2.9'),
('GEOS', '3.9.1'),
('SQLite', '3.33.0'),
('libxml2', '2.9.10'),
('libpng', '1.6.37'),
('libjpeg-turbo', '2.0.5'),
('JasPer', '2.0.24'),
('LibTIFF', '4.1.0'),
('zlib', '1.2.11'),
('cURL', '7.72.0'),
('PCRE2', '10.35'),
('PROJ', '7.2.1'),
('libgeotiff', '1.6.0'),
('SciPy-bundle', '2020.11'),
('HDF5', '1.10.7'),
('HDF', '4.2.15'),
]
preconfigopts = "sed -e 's/-llapack/\$LIBLAPACK/g' -i.eb configure && "
configopts = '--with-expat=$EBROOTEXPAT --with-libz=$EBROOTLIBZ'
configopts += ' --with-hdf5=$EBROOTHDF5 --with-netcdf=$EBROOTNETCDF'
configopts += ' --with-xml2=yes --with-geos=$EBROOTGEOS/bin/geos-config --with-jpeg=$EBROOTLIBJPEGMINTURBO'
configopts += ' --with-png=$EBROOTLIBPNG --with-sqlite3=$EBROOTSQLITE --with-jasper=$EBROOTJASPER'
configopts += ' --with-libtiff=$EBROOTLIBTIFF --with-pcre=$EBROOTPCRE2 --with-python=$EBROOTPYTHON/bin/python'
configopts += ' --with-geotiff=$EBROOTLIBGEOTIFF --with-hdf4=$EBROOTHDF'
modextrapaths = {'PYTHONPATH': 'lib/python%(pyshortver)s/site-packages'}
sanity_check_paths = {
'files': ['lib/libgdal.a', 'lib/libgdal.%s' % SHLIB_EXT],
'dirs': ['bin', 'include', 'lib/python%(pyshortver)s/site-packages']
}
sanity_check_commands = ["python -c 'import osgeo.gdal'"]
moduleclass = 'data'
##
# Author: Robert Mijakovic <robert.mijakovic@lxp.lu>
##
# IT4Innovations
# LK 2021
name = 'OpenFOAM'
version = 'v2106'
......@@ -10,7 +10,7 @@ description = """OpenFOAM is a free, open source CFD software package.
involving chemical reactions, turbulence and heat transfer,
to solid dynamics and electromagnetics."""
toolchain = {'name': 'foss', 'version': '2021a'}
toolchain = {'name': 'foss', 'version': '2020b'}
toolchainopts = {'cstd': 'c++11'}
source_urls = ['https://sourceforge.net/projects/openfoam/files/%(version)s/']
......@@ -26,19 +26,19 @@ checksums = [
]
dependencies = [
('libreadline', '8.1'),
('libreadline', '8.0'),
('ncurses', '6.2'),
# OpenFOAM requires 64 bit METIS using 32 bit indexes (array indexes)
('METIS', '5.1.0'),
('SCOTCH', '6.1.0'),
('CGAL', '4.14.3'),
('CGAL', '3.2.1'),
('ParaView', '5.9.1', '-mpi'),
('gnuplot', '5.4.2'),
]
builddependencies = [
('Bison', '3.7.6'),
('CMake', '3.20.1'),
('Bison', '3.7.1'),
('CMake', '3.18.4'),
('flex', '2.6.4'),
]
......
# IT4Innovations
# LK 2021
easyblock = 'CMakeMake'
name = 'ParaView'
version = '5.9.1'
versionsuffix = '-mpi'
homepage = "https://www.paraview.org"
description = "ParaView is a scientific parallel visualizer."
toolchain = {'name': 'foss', 'version': '2020b'}
toolchainopts = {'pic': True, 'usempi': True}
local_download_suffix = 'download.php?submit=Download&version=v%(version_major_minor)s&type=source&os=all&downloadFile='
source_urls = ['https://www.paraview.org/paraview-downloads/%s' % local_download_suffix]
sources = ["%(name)s-v%(version)s.tar.gz"]
checksums = ['efbcba00ba38c23d0ada1bde7144a8745caa308d9e1f94a4a71d8af63732266f']
dependencies = [
('Python', '3.8.6'),
('SciPy-bundle', '2020.11'),
('XZ', '5.2.5'),
('HDF5', '1.10.7'),
('netCDF', '4.7.4'),
('libGLU', '9.0.1'),
('X11', '20201008'),
('Mesa', '20.2.1'),
('Qt5', '5.14.2'),
('zlib', '1.2.11'),
('FFmpeg', '4.3.1'),
('Szip', '2.1.1'),
]
builddependencies = [('CMake', '3.18.4')]
separate_build_dir = True
# Paraview
configopts = '-DPARAVIEW_INSTALL_DEVELOPMENT_FILES=ON -DPARAVIEW_BUILD_SHARED_LIBS=ON '
configopts += '-DPARAVIEW_USE_MPI=ON '
configopts += '-DPARAVIEW_ENABLE_FFMPEG=ON '
configopts += '-DPARAVIEW_USE_PYTHON=ON '
configopts += '-DPython3_ROOT_DIR=$EBROOTPYTHON '
# OpenGL & Mesa
configopts += '-DOPENGL_glu_LIBRARY=$EBROOTLIBGLU/lib/libGLU.%s ' % SHLIB_EXT
configopts += '-DOPENGL_INCLUDE_DIR=$EBROOTMESA/include '
sanity_check_paths = {
'files': ['bin/paraview', 'bin/pvpython'],
'dirs': ['include/paraview-%(version_major_minor)s', 'lib/python%(pyshortver)s/site-packages'],
}
sanity_check_commands = ['python -c "import paraview"']
modextrapaths = {'PYTHONPATH': ['lib64/python%(pyshortver)s/site-packages', 'lib/python%(pyshortver)s/site-packages']}
moduleclass = 'vis'
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment