Commit e05ba9ea authored by Easy Build's avatar Easy Build

modified: h/h5py/h5py-2.9.0-Py-3.6.eb

	new file:   m/matplotlib/matplotlib-3.1.0-Py-3.6.eb
	modified:   p/phonopy/phonopy-2.1.3-Py-3.6.eb
parent 8f0b8faa
Pipeline #8077 passed with stage
in 14 seconds
......@@ -15,7 +15,7 @@ sources = [SOURCE_TAR_GZ]
dependencies = [
('HDF5', '1.10.4', '-parallel', ('gompi', '2017c')),
('numpy', '1.15.4'),
('numpy', '1.16.3'),
('mpi4py', '3.0.1'), # required for MPI support
('six', '1.11.0'),
]
......
# IT4Innovations 2019
easyblock = "PythonPackage"
name = 'matplotlib'
version = '3.1.0'
homepage = 'http://matplotlib.org'
description = """Matplotlib is a python 2D plotting library which produces publication quality figures in a variety of
hardcopy formats and interactive environments across platforms. matplotlib can be used in python scripts, the python
and ipython shell, web application servers, and six graphical user interface toolkits."""
toolchain = {'name': 'Py', 'version': '3.6'}
source_urls = ['https://github.com/matplotlib/matplotlib/archive/']
sources = ['v%(version)s.tar.gz']
dependencies = [
('freetype', '2.9.1', '-libpng-1.6.34', True),
('libpng', '1.6.34', '', True),
('python-dateutil', '2.6.1'),
('numpy', '1.16.3'),
('pyparsing', '2.2.0'),
('six', '1.11.0'),
]
sanity_check_paths = {'files': [], 'dirs': [
'lib/python3.6/site-packages/%(name)s-%(version)s-py3.6-linux-x86_64.egg/%(name)s'], }
moduleclass = 'python'
......@@ -14,7 +14,7 @@ source_urls = [PYPI_SOURCE]
sources = [SOURCE_TAR_GZ]
dependencies = [
('matplotlib', '3.0.2'),
('matplotlib', '3.1.0'),
('lxml', '4.3.0'),
('PyYAML', '3.13'),
('numpy', '1.16.3'),
......@@ -22,4 +22,10 @@ dependencies = [
('scipy', '1.3.0')
]
sanity_check_paths = {
'files': [],
'dirs': ['lib/python3.6/site-packages/%(name)s-%(version)s-py3.6-linux-x86_64.egg'],
}
moduleclass = 'python'
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment