Commit fff6655b authored by Lukáš Krupčík's avatar Lukáš Krupčík
Browse files

Merge branch 'easyconfigs-it4i-salomon'

parents 9f94e14b 066ce8a8
# Repozitář pro easyconfigy lišící se od upstreamu
## Branch master
[here](https://code.it4i.cz/kru0052/easyconfigs-it4i/tree/master)
## Branch easyconfigs-it4i-salomon
[here](https://code.it4i.cz/kru0052/easyconfigs-it4i/tree/easyconfigs-it4i-salomon)
## Branch easyconfigs-it4i-anselm
[here](https://code.it4i.cz/kru0052/easyconfigs-it4i/tree/easyconfigs-it4i-anselm)
name = 'QuantumESPRESSO'
version = '6.1'
homepage = 'http://www.pwscf.org/'
description = """Quantum ESPRESSO is an integrated suite of computer codes
for electronic-structure calculations and materials modeling at the nanoscale.
It is based on density-functional theory, plane waves, and pseudopotentials
(both norm-conserving and ultrasoft)."""
toolchain = {'name': 'intel', 'version': '2017a'}
toolchainopts = {'usempi': True}
# major part of this list was determined from espresso/install/plugins_list
sources = [
'qe-%(version)s.tar.gz',
'wannier90-2.1.0.tar.gz',
'qe-gipaw-6.1.tar.gz',
# must be downloaded manually from
# http://qe-forge.org/gf/project/q-e/scmsvn/?action=browse&path=%2F%2Acheckout%2A%2Ftags%2FQE-5.2.1%2Fespresso%2Farchive%2Fplumed-1.3-qe.tar.gz&revision=11758
# gets updated without changes to filename, cfr. http://qe-forge.org/pipermail/q-e-commits/2015-June/007359.html
# 'plumed-1.3-qe-r11758.tar.gz',
'want-2.5.1-base.tar.gz',
'West-2.0.1.tar.gz',
'yambo-3.4.2.tgz',
]
missing_sources = [
'sax-2.0.3.tar.gz', # nowhere to be found
]
source_urls = [
'http://files.qe-forge.org/index.php?file=', # all sources, except espresso*.tar.gz
'http://www.wannier.org/code/', # wannier90-2.1.0.tar.gz
'http://qe-forge.org/gf/download/frsrelease/240/1075/', # qe-6.1.tar.gz
'http://qe-forge.org/gf/download/frsrelease/153/618/', # want-2.5.1-base.tar.gz
'http://www.west-code.org/downloads/', # West-2.0.1.tar.gz
'http://qe-forge.org/gf/download/frsrelease/208/932/', # yambo-3.4.2.tgz
]
patches = [
'QuantumESPRESSO-5.4.0_yambo-fixes.patch',
]
# source checksums
checksums = [
'db398edcad76e085f8c8a3f6ecb7aaab', # qe-6.1.tar.gz
'07a81c002b41d6d0f97857e55c57d769', # wannier90-2.1.0.tar.gz
'178055353e59eb4dd8bebe27331f2927', # qe-gipaw-6.1.tar.gz
# 'f094031c6d13a0e00022daf4d7c847c7', # plumed-1.3-qe-r11758.tar.gz
'ac365daebbe380bf4019235eacf71079', # want-2.5.1-base.tar.gz
'000abe6a5dccd1e722d1767c3dcd3996', # West-2.0.1.tar.gz
'f0820a0f42dfc81ce3811af647bed777', # yambo-3.4.2.tgz
]
# add plumed and uncomment the lines in sources and checksums if the package is downloaded manually
buildopts = 'all w90 epw gipaw want west yambo xspectra' # plumed
# parallel build tends to fail
parallel = 1
moduleclass = 'chem'
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment