OpenMPI-2.0.2-GCC-6.3.0-2.27.eb 1.59 KB
Newer Older
Lukáš Krupčík's avatar
Lukáš Krupčík committed
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
easyblock = 'ConfigureMake'

name = 'OpenMPI'
version = '2.0.2'

homepage = 'http://www.open-mpi.org/'
description = """The Open MPI Project is an open source MPI-2 implementation."""

toolchain = {'name': 'GCC', 'version': '6.3.0-2.27'}

source_urls = ['http://www.open-mpi.org/software/ompi/v%(version_major_minor)s/downloads']
sources = [SOURCELOWER_TAR_GZ]
sources = ['openmpi-%(version)s.tar.gz']
checksums = ['886698becc5bea8c151c0af2074b8392']

16 17 18 19
dependencies = [
    ('hwloc', '1.11.7'),
    ('libxml2', '2.9.4', '', True),
]
Lukáš Krupčík's avatar
Lukáš Krupčík committed
20 21 22 23

configopts = '--with-threads=posix --enable-shared --enable-mpi-thread-multiple --with-verbs '
configopts += '--enable-mpirun-prefix-by-default '  # suppress failure modes in relation to mpirun path
configopts += '--with-hwloc=$EBROOTHWLOC '  # hwloc support
24
#configopts += '--disable-dlopen '  # dont disable dlopen! https://github.com/open-mpi/ompi/issues/3630
Lukáš Krupčík's avatar
Lukáš Krupčík committed
25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46
configopts += '--with-tm=/opt/pbs/default '  # Enable PBS

# for PBS Pro 13
preconfigopts = 'export LIBS="-ldl" && '

# needed for --with-verbs
osdependencies = [('libibverbs-dev', 'libibverbs-devel'),]

libs = ["mpi_mpifh", "mpi", "ompitrace", "open-pal", "open-rte"]

modextravars = {'OMPI_MCA_btl_openib_if_include': 'mlx4_0',
                'OMPI_MCA_oob_tcp_if_include': '10.0.0.0/8',
}

sanity_check_paths = {
    'files': ["bin/%s" % binfile for binfile in ["ompi_info", "opal_wrapper", "orterun"]] +
             ["lib/lib%s.%s" % (libfile, SHLIB_EXT) for libfile in libs] +
             ["include/%s.h" % x for x in ["mpi-ext", "mpif-config", "mpif", "mpi", "mpi_portable_platform"]],
    'dirs': [],
}

moduleclass = 'mpi'