Commit 490192be authored by Lukáš Krupčík's avatar Lukáš Krupčík

modified: i/icc/icc-2017.1.132-GCC-5.4.0-2.26.eb

	new file:   r/Ruby/Ruby-2.4.2.eb
parent 95cec4b9
......@@ -30,4 +30,9 @@ dontcreateinstalldir = 'True'
license_file = '/apps/licenses/intel/license.lic'
sanity_check_paths = {
'files': [],
'dirs': ['include'],
}
moduleclass = 'compiler'
name = 'Ruby'
version = '2.4.2'
homepage = 'https://www.ruby-lang.org'
description = """Ruby is a dynamic, open source programming language with
a focus on simplicity and productivity. It has an elegant syntax that is
natural to read and easy to write."""
toolchain = {'name': 'dummy', 'version': ''}
sources = [SOURCELOWER_TAR_GZ]
source_urls = ['http://cache.ruby-lang.org/pub/ruby/']
ext_options = {
'source_urls': ['http://rubygems.org/downloads/'],
'source_tmpl': '%(name)s-%(version)s.gem',
}
exts_list = [
('ffi', '1.9.14', ext_options),
('childprocess', '0.5.9', ext_options),
('json', '2.0.2', ext_options),
('cabin', '0.9.0', ext_options),
('backports', '3.6.8', ext_options),
('arr-pm', '0.0.10', ext_options),
('clamp', '1.1.1', ext_options),
('multipart-post', '2.0.0', ext_options),
('faraday', '0.10.0', ext_options),
('faraday_middleware', '0.10.1', ext_options),
('highline', '1.7.8', ext_options),
('net-http-pipeline', '1.0.1', ext_options),
('net-http-persistent', '2.9.4', ext_options),
('multi_json', '1.12.1', ext_options),
('public_suffix', '2.0.4', ext_options),
('addressable', '2.4.0', ext_options),
('gh', '0.15.0', ext_options),
('launchy', '2.4.3', ext_options),
('ethon', '0.10.1', ext_options),
('typhoeus', '0.6.9', ext_options),
('websocket', '1.2.3', ext_options),
('pusher-client', '0.6.2', ext_options),
('diff-lcs', '1.2.5', ext_options),
('rspec-support', '3.5.0', ext_options),
('rspec-mocks', '3.5.0', ext_options),
('rspec-expectations', '3.5.0', ext_options),
('rspec-core', '3.5.4', ext_options),
('rspec', '3.5.0', ext_options),
('rack', '1.6.5', ext_options),
('rack-protection', '1.5.3', ext_options),
('tilt', '2.0.5', ext_options),
('sinatra', '1.4.7', ext_options),
('rack-test', '0.6.3', ext_options),
('faraday', '0.12.0.1', ext_options),
]
moduleclass = 'lang'
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment