Commit 6c96bdd1 authored by Lukáš Krupčík's avatar Lukáš Krupčík

new file: l/LLVM/LLVM-6.0.1.eb

	new file:   l/LLVM/LLVM-7.0.0.eb
	new file:   m/Mako/Mako-1.0.6-Python-2.7.14-base.eb
	new file:   m/Mesa/Mesa-18.3.1.eb
	new file:   n/nettle/nettle-3.4.1.eb
	new file:   p/ParaView/ParaView-5.6.0-intel-2017a-mpi.eb
	new file:   p/ParaView/ParaView-5.6.0-intel-motionfx.patch
	new file:   q/QEMU/QEMU-2.10.0-VDE2.eb
	new file:   v/VDE2/VDE2-2.3.2.eb
	deleted:    l/LLVM/LLVM-7.0.0-GCC-6.3.0-2.27.eb
parent 085bbfed
Pipeline #5559 passed with stage
in 15 seconds
# IT4Innovations 2018
easyblock = 'CMakeMake'
name = 'LLVM'
version = '6.0.1'
homepage = "http://llvm.org/"
description = """The LLVM Core libraries provide a modern source- and target-independent
optimizer, along with code generation support for many popular CPUs
(as well as some less common ones!) These libraries are built around a well
specified code representation known as the LLVM intermediate representation
("LLVM IR"). The LLVM Core libraries are well documented, and it is
particularly easy to invent your own language (or port an existing compiler)
to use LLVM as an optimizer and code generator."""
toolchain = {'name': 'dummy', 'version': ''}
toolchainopts = {'cstd': 'gnu++11'}
source_urls = ["http://llvm.org/releases/%(version)s"]
sources = ["llvm-%(version)s.src.tar.xz"]
builddependencies = [
('CMake', '3.9.0', '', True),
('Python', '2.7.14', '-base', True),
]
dependencies = [
('ncurses', '6.0', '', True),
('zlib', '1.2.11', '', True),
]
configopts = '-DBUILD_SHARED_LIBS=ON -DCMAKE_EXE_LINKER_FLAGS="$LDFLAGS" '
# required to install extra tools in bin/
configopts += "-DLLVM_INSTALL_UTILS=ON -DLLVM_TARGETS_TO_BUILD=X86 -DLLVM_ENABLE_ZLIB=ON -DLLVM_ENABLE_RTTI=1 "
configopts += "-DCMAKE_BUILD_TYPE=Release "
sanity_check_paths = {
'files': ['bin/llvm-ar', 'bin/FileCheck'],
'dirs': ['include/llvm', 'include/llvm-c'],
}
separate_build_dir = True
moduleclass = 'compiler'
......@@ -14,15 +14,15 @@ description = """The LLVM Core libraries provide a modern source- and target-ind
particularly easy to invent your own language (or port an existing compiler)
to use LLVM as an optimizer and code generator."""
toolchain = {'name': 'GCC', 'version': '6.3.0-2.27'}
toolchain = {'name': 'dummy', 'version': ''}
toolchainopts = {'cstd': 'gnu++11'}
source_urls = ["http://llvm.org/releases/%(version)s"]
sources = ["llvm-%(version)s.src.tar.xz"]
builddependencies = [
('CMake', '3.13.1', '', True),
('Py', '2.7', '', True),
('CMake', '3.9.0', '', True),
('Python', '2.7.14', '-base', True),
]
dependencies = [
......@@ -30,7 +30,7 @@ dependencies = [
('zlib', '1.2.11', '', True),
]
configopts = '-DBUILD_SHARED_LIBS=ON -DCMAKE_EXE_LINKER_FLAGS="$LDFLAGS -shared-intel" '
configopts = '-DBUILD_SHARED_LIBS=ON -DCMAKE_EXE_LINKER_FLAGS="$LDFLAGS" '
# required to install extra tools in bin/
configopts += "-DLLVM_INSTALL_UTILS=ON -DLLVM_TARGETS_TO_BUILD=X86 -DLLVM_ENABLE_ZLIB=ON -DLLVM_ENABLE_RTTI=1 "
configopts += "-DCMAKE_BUILD_TYPE=Release "
......
easyblock = 'PythonPackage'
name = 'Mako'
version = '1.0.6'
versionsuffix = '-Python-%(pyver)s-base'
homepage = 'http://www.makotemplates.org'
description = """A super-fast templating language that borrows the best ideas from the existing templating languages"""
toolchain = {'name': 'dummy', 'version': ''}
source_urls = [PYPI_SOURCE]
sources = [SOURCE_TAR_GZ]
dependencies = [('Python', '2.7.14', '-base')]
sanity_check_paths = {
'files': ['bin/mako-render'],
'dirs': ['lib/python%(pyshortver)s/site-packages/%(name)s-%(version)s-py%(pyshortver)s.egg'],
}
moduleclass = 'devel'
# IT4Innovations 2018
easyblock = 'ConfigureMake'
name = 'Mesa'
version = '18.3.1'
homepage = 'http://www.mesa3d.org/'
description = """Mesa is an open-source implementation of the OpenGL specification -
a system for rendering interactive 3D graphics."""
toolchain = {'name': 'dummy', 'version': ''}
# swr detects and builds parts specific for AVX and AVX2. If we use
# -xHost, this always gets overwritten and will fail.
toolchainopts = {'optarch': False}
sources = [SOURCELOWER_TAR_XZ]
source_urls = [
'https://mesa.freedesktop.org/archive/',
'https://mesa.freedesktop.org/archive/%(version)s',
'ftp://ftp.freedesktop.org/pub/mesa/%(version)s',
'ftp://ftp.freedesktop.org/pub/mesa/older-versions/%(version_major)s.x/%(version)s',
]
#patches = ['Mesa-17.0.2_fix-strip-llvm-flags.patch']
builddependencies = [
('flex', '2.6.4', '', True),
('Bison', '3.0.5', '', True),
('Autotools', '20180311', '', True),
('pkg-config', '0.29.2', '', True),
('Mako', '1.0.6', '-Python-2.7.14-base', True),
('libxml2', '2.9.4', '', True),
]
dependencies = [
('zlib', '1.2.11', '', True),
('nettle', '3.4.1'),
('libdrm', '2.4.76', '', True),
('LLVM', '6.0.1'),
('X11', '20170314', '', True),
('expat', '2.2.0', '', True),
]
# GLU is not part anymore of Mesa package!
configopts = " --disable-osmesa --enable-gallium-osmesa --enable-gallium-llvm --enable-glx --disable-dri"
configopts += " --disable-gbm --disable-driglx-direct --with-gallium-drivers='swrast,swr' --disable-egl"
configopts += " --with-osmesa-bits=32 --enable-texture-float --enable-llvm-shared-libs "
buildopts = 'V=1'
sanity_check_paths = {
'files': [
'lib/libGL.%s' %
SHLIB_EXT,
'lib/libOSMesa.%s' %
SHLIB_EXT,
'lib/libGLESv1_CM.%s' %
SHLIB_EXT,
'lib/libGLESv2.%s' %
SHLIB_EXT,
'include/GL/glext.h',
'include/GL/gl_mangle.h',
'include/GL/glx.h',
'include/GL/osmesa.h',
'include/GL/gl.h',
'include/GL/glxext.h',
'include/GL/glx_mangle.h',
'include/GLES/gl.h',
'include/GLES2/gl2.h',
'include/GLES3/gl3.h'],
'dirs': []}
moduleclass = 'vis'
# IT4Innovations 2018
easyblock = 'ConfigureMake'
name = 'nettle'
version = '3.4.1'
homepage = 'http://www.lysator.liu.se/~nisse/nettle/'
description = """Nettle is a cryptographic library that is designed to fit easily
in more or less any context: In crypto toolkits for object-oriented
languages (C++, Python, Pike, ...), in applications like LSH or GNUPG,
or even in kernel space."""
toolchain = {'name': 'dummy', 'version': ''}
source_urls = [GNU_SOURCE]
sources = [SOURCE_TAR_GZ]
configopts = 'CFLAGS="-std=c99"'
dependencies = [
('GMP', '6.1.2'),
]
sanity_check_paths = {
'files': [
'bin/%s' %
x for x in [
'nettle-hash',
'nettle-lfib-stream',
'pkcs1-conv',
'sexp-conv']] +
[
'lib64/libhogweed.a',
'lib64/libhogweed.%s' %
SHLIB_EXT,
'lib64/libnettle.a',
'lib64/libnettle.%s' %
SHLIB_EXT],
'dirs': ['include/nettle'],
}
moduleclass = 'lib'
# IT4Innovations
easyblock = 'CMakeMake'
name = 'ParaView'
version = '5.6.0'
versionsuffix = '-mpi'
homepage = "http://www.paraview.org"
description = "ParaView is a scientific parallel visualizer."
toolchain = {'name': 'intel', 'version': '2017a'}
toolchainopts = {'pic': True, 'usempi': True}
download_suffix = 'download.php?submit=Download&version=v%(version_major_minor)s&type=source&os=all&downloadFile='
source_urls = [
'http://www.paraview.org/paraview-downloads/%s' %
download_suffix]
sources = ["ParaView-v%(version)s.tar.gz"]
#patches = ['ParaView-5.6.0-intel-motionfx.patch']
dependencies = [
('X11', '20170314', '', True),
('Mesa', '18.3.1', '', True),
('libGLU', '9.0.0', '', True),
('Qt5', '5.8.0', '', ('GCC', '6.3.0-2.27')),
('zlib', '1.2.11', '', True),
('HDF5', '1.8.17'),
('Python', '2.7.14', '-base', True),
]
builddependencies = [('CMake', '3.13.1', '', True)]
separate_build_dir = True
configopts = '-DPARAVIEW_INSTALL_DEVELOPMENT_FILES=ON -DVTK_OPENGL_HAS_OSMESA=ON -DPARAVIEW_USE_MPI=ON '
configopts += '-DOPENGL_INCLUDE_DIR=$EBROOTMESA/include -DOPENGL_gl_LIBRARY=$EBROOTMESA/lib/libGL.%s ' % SHLIB_EXT
configopts += '-DOSMESA_INCLUDE_DIR=$EBROOTMESA/include -DOSMESA_LIBRARY=$EBROOTMESA/lib/libOSMesa.%s ' % SHLIB_EXT
configopts += '-DOPENGL_glu_LIBRARY=$EBROOTLIBGLU/lib/libGLU.%s ' % SHLIB_EXT
configopts += '-DVTK_USE_SYSTEM_HDF5=ON -DPARAVIEW_ENABLE_PYTHON=ON -DBUILD_SHARED_LIBS=ON -DVTK_RENDERING_BACKEND=OpenGL2 '
configopts += '-DPARAVIEW_QT_VERSION=5 -DPARAVIEW_INSTALL_DEVELOPMENT_FILES=ON '
configopts += '-DPARAVIEW_ENABLE_MOTIONFX=OFF ' # This is broken in 5.6.0
# if you want to build server only Paraview, uncomment the following line:
# configopts += '-DVTK_USE_X=OFF '
# Without internet connection turn off testing (uncomment the following line)
configopts += '-DBUILD_TESTING=OFF '
# Or consult https://gitlab.kitware.com/vtk/vtk/blob/master/Documentation/dev/git/data.md
# and download ExternalData to $EASYBUILD_SOURCEPATH and adjust -DExternalData_OBJECT_STORES accordingly
# Without internet connection, comment the following two lines (configopts and prebuildopts)
#configopts += '-DExternalData_OBJECT_STORES=%(builddir)s/ExternalData '
# The ParaView server can be cranky, test downloads are quite often failing, especially in the case
# of parallel downloads. Using ; insted of && gives a second chance to download the test files, if the
# first serial attempt would fail.
#prebuildopts = 'make VTKData ;'
moduleclass = 'vis'
diff --git a/CMake/VTKModules.cmake b/CMake/VTKModules.cmake
index ad4988ffd0..38c7e067a1 100644
--- a/CMake/VTKModules.cmake
+++ b/CMake/VTKModules.cmake
@@ -377,12 +377,12 @@ set(_vtk_modules
# needed for vtkVeraOutReader
)
-if ((NOT WIN32) OR (NOT MSVC) OR (MSVC_VERSION GREATER 1899))
- # MSVC 2015 (1900) or newer is needed if using MVSC for vtkIOMotionFX
- list(APPEND _vtk_modules
- vtkIOMotionFX # needed for vtkMotionFXCFGReader
- )
-endif()
+#if ((NOT WIN32) OR (NOT MSVC) OR (MSVC_VERSION GREATER 1899))
+# # MSVC 2015 (1900) or newer is needed if using MVSC for vtkIOMotionFX
+# list(APPEND _vtk_modules
+# vtkIOMotionFX # needed for vtkMotionFXCFGReader
+# )
+#endif()
list(APPEND _vtk_modules vtkRenderingLICOpenGL2)
easyblock = 'ConfigureMake'
name = "QEMU"
version = "2.10.0"
versionsuffix = "-VDE2"
homepage = 'http://wiki.qemu.org/Main_Page'
description = """QEMU is a generic and open source machine emulator and
virtualizer."""
configopts = "--target-list=x86_64-softmmu,x86_64-linux-user,i386-softmmu,i386-linux-user"
toolchain = {'name': 'dummy', 'version': ''}
sources = [SOURCELOWER_TAR_BZ2]
source_urls = ['http://wiki.qemu-project.org/download/']
patches = ['qemu-slirp-smb-2.9.0.patch']
dependencies = [
('VDE2', '2.3.2'),
('GLib','2.57.1'),
]
sanity_check_paths = {
'files': ['bin/qemu-x86_64'],
'dirs': ['bin', 'share'],
}
moduleclass = 'tools'
# Built with EasyBuild version 2.1.1 on 2015-09-17_10-51-16
easyblock = 'ConfigureMake'
name = "VDE2"
version = "2.3.2"
homepage = 'http://vde.sourceforge.net'
description = """VDE is an ethernet compliant virtual network that
can be spawned over a set of physical computer over the Internet.
VDE is part of virtualsquare project."""
toolchain = {'name': 'dummy', 'version': ''}
sources = [SOURCELOWER_TAR_BZ2]
source_urls = ['https://netix.dl.sourceforge.net/project/vde/vde2/%(version)s/']
patches = ['vde2-slirpvde-sigpipe.patch']
sanity_check_paths = {
'files': ['bin/vde_switch'],
'dirs': ['bin', 'etc', 'share'],
}
# It fails in case of default value
parallel = 1
modextravars = {
'VDE2_HOME': '%(installdir)s',
'VDE2_DIR': '%(installdir)s',
}
moduleclass = 'tools'
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment