Commit 7d4d7de9 authored by Josef Hrabal's avatar Josef Hrabal

new file: b/Boost/Boost-1.68.0-foss-2019a.eb

	new file:   g/GTK+/GTK+-3.24.8-GCCcore-8.2.0.eb
	new file:   m/Meld/Meld-3.20.1-Python-3.7.2.eb
	new file:   o/OpenMPI/OpenMPI-3.1.4-GCC-6.3.0-2.27.eb
	new file:   r/RSPt/RSPTmake.inc
	new file:   r/RSPt/RSPt-1.1-intel-2017c.eb
	new file:   r/RSPt/RSPt-1.1-intel-2017c.patch
	new file:   s/SPRKKR/SPRKKR-7.7.2-intel-2017c.eb
	new file:   s/SPRKKR/SPRKKR-7.7.2-intel-2017c.patch
	deleted:    p/PyGTK/PyGTK-2.24.0-Python-2.7.13.eb
parent ba73636d
Pipeline #8534 failed with stage
in 16 seconds
# IT4Innovations 2019
name = 'Boost'
version = '1.68.0'
homepage = 'http://www.boost.org/'
description = """Boost provides free peer-reviewed portable C++ source libraries."""
toolchain = {'name': 'foss', 'version': '2019a'}
toolchainopts = {'pic': True, 'usempi': True}
source_urls = [SOURCEFORGE_SOURCE]
sources = ['%%(namelower)s_%s.tar.gz' % '_'.join(version.split('.'))]
dependencies = [
('bzip2', '1.0.6', '', True),
('zlib', '1.2.11', '', True),
]
configopts = '--without-libraries=python'
# also build boost_mpi
boost_mpi = True
moduleclass = 'devel'
# IT4Innovations 2019
easyblock = 'ConfigureMake'
name = 'GTK+'
version = '3.24.8'
homepage = 'https://developer.gnome.org/gtk+/stable/'
description = """
The GTK+ 2 package contains libraries used for creating graphical user interfaces for applications.
"""
toolchain = {'name': 'GCCcore', 'version': '8.2.0'}
source_urls = [FTPGNOME_SOURCE]
sources = [SOURCELOWER_TAR_XZ]
checksums = ['666962de9b9768fe9ca785b0e2f42c8b9db3868a12fa9b356b167238d70ac799']
builddependencies = [
('binutils', '2.31.1'),
('GObject-Introspection', '1.60.1', '-Python-3.7.2'),
('gettext', '0.19.8.1'),
('pkg-config', '0.29.2'),
('cairo', '1.16.0'),
('Perl', '5.28.1'),
]
dependencies = [
('ATK', '2.32.0'),
('at-spi2-atk', '2.32.0'),
('Gdk-Pixbuf', '2.38.1'),
('Pango', '1.43.0'),
('libepoxy', '1.5.3'),
('X11', '20190311'),
('FriBidi', '1.0.5'),
]
configopts = "--disable-silent-rules --disable-glibtest --enable-introspection=yes --disable-visibility "
sanity_check_paths = {
'files': ['bin/gtk-update-icon-cache', 'lib/libgtk-%%(version_major)s.%s' % SHLIB_EXT],
'dirs': ['include/gtk-%(version_major)s.0'],
}
modextrapaths = {
'GI_TYPELIB_PATH': 'share',
'XDG_DATA_DIRS': 'share',
}
moduleclass = 'vis'
# IT4Innovations 2019
easyblock = 'PythonPackage'
name = 'Meld'
version = '3.20.1'
homepage = 'https://meldmerge.org/'
description = """Meld is a visual diff and merge tool targeted at developers. Meld helps you compare files, directories, and version controlled projects. It provides two- and three-way comparison of both files and directories, and has support for many popular version control systems."""
toolchain = {'name': 'GCCcore', 'version': '8.2.0'}
source_urls = ['https://download.gnome.org/sources/meld/3.20/']
sources = ['meld-%(version)s.tar.xz']
dependencies = [
('Python', '3.7.2'),
('GTK+', '3.24.8'),
('GLib', '2.60.1'),
('cairo', '1.16.0'),
('GObject-Introspection', '1.60.1', '-Python-3.7.2'),
]
sanity_check_paths = {'files': [], 'dirs': [
'lib/python3.7/site-packages/meld'], }
moduleclass = 'python'
# IT4Innovations 2019
easyblock = 'ConfigureMake'
name = 'OpenMPI'
version = '3.1.4'
homepage = 'http://www.open-mpi.org/'
description = """The Open MPI Project is an open source MPI-2 implementation."""
toolchain = {'name': 'GCC', 'version': '6.3.0-2.27'}
source_urls = [
'http://www.open-mpi.org/software/ompi/v%(version_major_minor)s/downloads']
sources = [SOURCELOWER_TAR_GZ]
builddependencies = [
('Java', '1.8.0_121', '', True)
]
dependencies = [
('hwloc', '1.11.7'),
('zlib', '1.2.11', '', True),
('libxml2', '2.9.4', '', True),
]
configopts = '--enable-shared --enable-mpi-thread-multiple --with-verbs '
# suppress failure modes in relation to mpirun path
configopts += '--enable-mpirun-prefix-by-default '
configopts += '--with-hwloc=$EBROOTHWLOC ' # hwloc support
# configopts += '--disable-dlopen ' # dont disable dlopen!
# https://github.com/open-mpi/ompi/issues/3630
configopts += '--with-tm=/opt/pbs/default ' # Enable PBS
configopts += '--enable-mpi-java ' # Java support RT#4090
configopts += '--enable-mpi-cxx ' # Enable building the C++ MPI bindings
# for PBS Pro 13
preconfigopts = 'export LIBS="-ldl" && '
# to enable SLURM integration (site-specific)
# configopts += '--with-slurm --with-pmi=/usr/include/slurm --with-pmi-libdir=/usr'
# needed for --with-verbs
osdependencies = [('libibverbs-dev', 'libibverbs-devel', 'rdma-core-devel')]
libs = ["mpi_mpifh", "mpi", "ompitrace", "open-pal", "open-rte"]
sanity_check_paths = {
'files': [
"bin/%s" %
binfile for binfile in [
"ompi_info", "opal_wrapper", "orterun"]] + [
"lib/lib%s.%s" %
(libfile, SHLIB_EXT) for libfile in libs] + [
"include/%s.h" %
x for x in [
"mpi-ext", "mpif-config", "mpif", "mpi", "mpi_portable_platform"]], 'dirs': [], }
modextravars = {'OMPI_MCA_btl_openib_if_include': 'mlx4_0',
'OMPI_MCA_oob_tcp_if_include': '10.0.0.0/8',
}
moduleclass = 'mpi'
easyblock = 'ConfigureMake'
name = 'PyGTK'
version = '2.24.0'
homepage = 'http://www.pygtk.org/'
description = """PyGTK lets you to easily create programs with a graphical user interface
using the Python programming language."""
toolchain = {'name': 'dummy', 'version': ''}
source_urls = [PYPI_SOURCE]
sources = [SOURCELOWER_TAR_BZ2]
#patches = ['pygtk-2.24.0.patch']
pyver = '2.7.13'
pyshortver = '.'.join(pyver.split('.')[:2])
versionsuffix = '-Python-%s' % pyver
glibver = '2.52.0'
dependencies = [
('Python', pyver),
('GLib', glibver),
('PyGObject', '2.28.6', versionsuffix),
# ('GTK+', '2.24.28'),
# ('ATK', '2.18.0'),
('cairo', '1.14.12'),
# ('libglade', '2.6.4'),
]
postinstallcmds = [
"sed -i s#'codegendir=${datadir}'#codegendir=$EBROOTPYGOBJECT/share# %(installdir)s/lib/pkgconfig/pygtk-2.0.pc",
"sed -i s#'exec_prefix=${prefix}'#exec_prefix=$EBROOTPYGOBJECT# %(installdir)s/bin/pygtk-codegen-2.0",
]
modextrapaths = {
'PYTHONPATH': [
'lib/python%s/site-packages' % pyshortver,
'lib64/python%s/site-packages' % pyshortver,
'lib/python%s/site-packages/gtk-%%(version_major)s.0' % pyshortver,
'lib64/python%s/site-packages/gtk-%%(version_major)s.0' % pyshortver,
],
}
sanity_check_paths = {
'files': ['lib/pkgconfig/pygtk-%(version_major)s.0.pc'],
'dirs': ['lib/pygtk'],
}
# sanity_check_commands = [
# ('python', "-c 'import gtk'"),
# ('python', "-c 'import gtk.glade'"),
#]
moduleclass = 'vis'
#RSPTautomake: ifort -DMPI
#FORTRAN:
FCOMPILER = mpiifort
F90COMPILER = mpiifort
FCOMPILERFLAGS = -O2
FCPPFLAGS = -DMPI
FORTRANLIBS = -lifcore -lsvml -lirc -lifport -limf
#C:
CCOMPILER = mpiicc
CCOMPILERFLAGS = -O2
CPPFLAGS = -DMPI
#LIBRARIES AND INCLUDE DIRECTORIES
LAPACKLIB =
BLASLIB = -lmkl_intel_lp64 -lmkl_sequential -lmkl_core
FFTWLIB = -L/apps/all/FFTW/3.3.8-intel-2017c/lib -lfftw3
#EXTRALIBS = -lmpi_f77 -lmpi_f90
INCLUDEDIRS = -I/apps/all/FFTW/3.3.8-intel-2017c/lib/../include
# IT4Innovations 2019
easyblock = 'MakeCp'
name = 'RSPt'
version = '1.1'
homepage = 'http://www.physics.uu.se/research/materials-theory/ongoing-research/code-development/rspt-main/'
description = """RSPt is a code for electronic structure calculations
and its acronym stands for Relativistic Spin Polarized toolkit."""
toolchain = {'name': 'intel', 'version': '2017c'}
sources = ['rspt-master.zip']
patches = ['RSPt-1.1-intel-2017c.patch']
dependencies = [
('FFTW', '3.3.8'),
]
maxparallel = 1
files_to_copy = ["bin", "documentation", "include", "lib", "testsuite"]
sanity_check_paths = {
'files': ['bin/atan2of', 'lib/libjxwac.a'],
'dirs': []
}
moduleclass = 'phys'
--- RSPTmakes/RSPTautomake/RSPTautomake.sh.orig 2019-08-09 13:45:12.038398676 +0200
+++ RSPTmakes/RSPTautomake/RSPTautomake.sh 2019-08-09 13:48:37.184735110 +0200
@@ -168,8 +168,8 @@
echo "#RSPTautomake: " $FCOMPILER $FCPPFLAGS > ../../RSPTmake.inc
if [ -n "$FCPPFLAGS" ]
then
- CCOMPILER="mpicc"
- FCOMPILER="mpif90"
+ CCOMPILER="mpiicc"
+ FCOMPILER="mpiifort"
fi
echo "#FORTRAN:">> ../../RSPTmake.inc
echo "FCOMPILER =" $FCOMPILER >> ../../RSPTmake.inc
@@ -185,7 +185,7 @@
echo "LAPACKLIB =" $LAPACKLIB >> ../../RSPTmake.inc
echo "BLASLIB =" $BLASLIB >> ../../RSPTmake.inc
echo "FFTWLIB =" $FFTWLIB >> ../../RSPTmake.inc
- echo "EXTRALIBS =" $EXTRALIBS >> ../../RSPTmake.inc
+# echo "EXTRALIBS =" $EXTRALIBS >> ../../RSPTmake.inc
echo "INCLUDEDIRS =" $INCLUDEDIRS >> ../../RSPTmake.inc
else
echo "RSPTautomake failed to find a suitable FCOMPILER. Please load the appropriate modules and try again."
# IT4Innovations 2019
easyblock = 'MakeCp'
name = 'SPRKKR'
version = '7.7.2'
homepage = 'http://olymp.cup.uni-muenchen.de/index.php?option=com_content&view=article&id=8&catid=4&Itemid=7&lang=en'
description = """The SPRKKR band structure package allows to calculate the electronic
structure of arbitrary 3-D periodic systems, including systems with chemical disorder."""
toolchain = {'name': 'intel', 'version': '2017c'}
sources = ['SPRKKR7_7_2.zip']
patches = ['SPRKKR-7.7.2-intel-2017c.patch']
dependencies = [
('git', '2.21.0', '', True),
('dos2unix', '7.4.0', '', True),
]
prebuildopts = "dos2unix gitstamp.sh && chmod +x gitstamp.sh && mkdir bin && "
buildopts = "allmpi"
maxparallel = 1
files_to_copy = ["bin"]
sanity_check_paths = {
'files': ['bin/embgen7.7.2MPI', 'bin/kkrchi7.7.2MPI'],
'dirs': []
}
moduleclass = 'phys'
--- make.inc.orig 2017-07-31 11:14:42.000000000 +0200
+++ make.inc 2019-08-12 12:22:26.599183838 +0200
@@ -2,7 +2,7 @@
# Here the common makefile starts which does depend on the OS ####
###############################################################################
#
-# FC: compiler name and common options e.g. f77 -c
+# FC: compiler name and common options e.g. f77 -c
# LINK: linker name and common options e.g. g77 -shared
# FFLAGS: optimization e.g. -O3
# OP0: force nooptimisation for some routiens e.g. -O0
@@ -10,45 +10,48 @@
# LIB: library names e.g. -L/usr/lib -latlas -lblas -llapack
# (lapack and blas libraries are needed)
# BUILD_TYPE: string "debug" switches on debugging options
-# (NOTE: you may call, e.g. "make scf BUILD_TYPE=debug"
+# (NOTE: you may call, e.g. "make scf BUILD_TYPE=debug"
# to produce executable with debugging flags from command line)
-# BIN: directory for executables
+# BIN: directory for executables
# INCLUDE: directory for include files
-# (NOTE: directory with mpi include files has to be properly set
+# (NOTE: directory with mpi include files has to be properly set
# even for sequential executable)
###############################################################################
-BUILD_TYPE ?=
-BUILD_TYPE := debug
+BUILD_TYPE ?=
+#BUILD_TYPE := debug
-VERSION = 7.7.0
+VERSION = 7.7.2
ifeq ($(BUILD_TYPE), debug)
VERSION := $(VERSION)$(BUILD_TYPE)
endif
#BIN = .
- BIN=~/bin
+ BIN=bin
#BIN=/tmp/$(USER)
-LIB = $(LIB_MKL)
+LIB = $(LIB_MKL)
-LIBMPI =
+LIBMPI =
-# Include mpif.h
-INCLUDE = -I/usr/lib/openmpi/include
+# Include mpif.h
+#INCLUDE = -I/apps/all/impi/2017.4.239-iccifort-2017.7.259-GCC-6.3.0-2.27/intel64/include
-OP0 =
+OP0 =
ifeq ($(BUILD_TYPE), debug)
FFLAGS = -O0 -check all -traceback -fpe0 -g -fp-stack-check -ftrapuv -CU
else
- FFLAGS = -O2 -axSSE4.2 -diag-disable remark
+ FFLAGS = -O2 -xHost -diag-disable remark
endif
+BLAS=-L$(EBROOTIMKL)/mkl/lib/intel64 -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core -lpthread -liomp5
-FC = mpif90.openmpi -c -w $(FFLAGS) $(INCLUDE)
-LINK = mpif90.openmpi $(FFLAGS) $(INCLUDE)
+LAPACK=-L$(EBROOTIMKL)/mkl/lib/intel64 -lmkl_lapack
+
+FC = mpiifort -c -w $(FFLAGS) $(INCLUDE)
+LINK = mpiifort $(FFLAGS) $(INCLUDE) $(BLAS) $(LAPACK)
MPI=MPI
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment