Commit 9983345c authored by Lukáš Krupčík's avatar Lukáš Krupčík

modified: k/Keras_Applications/Keras_Applications-1.0.6-Py-3.6.eb

	modified:   m/mock/mock-2.0.0-Py-3.6.eb
	new file:   n/numpy/numpy-1.15.4-Python-3.6.1.eb
	new file:   t/Tensorflow/Tensorflow-1.12.0-GCC-6.3.0-2.27-Python-3.6.1.eb
parent 52efcf2d
Pipeline #5481 passed with stage
in 14 seconds
......@@ -12,6 +12,10 @@ toolchain = {'name': 'Py', 'version': '3.6'}
source_urls = [PYPI_SOURCE]
sources = ['Keras_Applications-1.0.6.tar.gz']
dependencies = [
('GCC', '6.3.0-2.27', '', True),
]
sanity_check_paths = {
'files': ['lib/python3.6/site-packages/%(name)s-%(version)s-py3.6.egg'],
'dirs': [],
......
......@@ -18,7 +18,7 @@ dependencies = [
sanity_check_paths = {
'files': [],
'dirs': ['lib/python3.6/site-packages/mock-2.0.0-py3.6.egg-info/'],
'dirs': ['lib/python3.6/site-packages/'],
}
moduleclass = 'python'
# IT4Innovations 2018
easyblock = 'PythonPackage'
name = 'numpy'
version = '1.15.4'
homepage = 'http://www.numpy.org'
description = """NumPy is the fundamental package needed for scientific computing with Python."""
toolchain = {'name': 'GCC', 'version': '6.3.0-2.27'}
source_urls = ['https://github.com/numpy/numpy/releases/download/v%(version)s']
sources = [SOURCE_TAR_GZ]
patch = [
'numpy-1.8.1-mkl.patch',
'numpy-1.11.0-sse42.patch'
]
dependencies = [
('Python', '3.6.1', '', True),
('mkl', '2017.4.239', '', True),
]
sanity_check_paths = {'files': [], 'dirs': [
'lib/python3.6/site-packages/%(name)s-%(version)s-py3.6-linux-x86_64.egg/numpy'], }
sanity_check_commands = [
('python', '-c "import numpy; assert(numpy.__version__ == \'%(version)s\')"')]
moduleclass = 'python'
# IT4Innovations 2018
easyblock = 'PythonPackage'
name = 'Tensorflow'
version = '1.12.0'
versionsuffix = '-Python-3.6.1'
homepage = 'https://www.tensorflow.org/'
description = "An open-source software library for Machine Intelligence"
toolchain = {'name': 'GCC', 'version': '6.3.0-2.27'}
sources = [
'tensorflow-%(version)s-cp36-cp36m-linux_x86_64.whl',
]
dependencies = [
('Python', '3.6.1', '', True),
]
use_pip = True
unpack_sources = False
sanity_check_paths = {
'files': ['bin/tensorboard'],
'dirs': ['lib/python3.6/site-packages/tensorflow-1.12.0.dist-info/'],
}
moduleclass = 'lib'
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment