Commit 99d75d04 authored by Lukáš Krupčík's avatar Lukáš Krupčík

new file: d/dotNET-Core-Runtime/dotNET-Core-Runtime-2.2.0.eb

	new file:   d/dotNET-Core-SDK/dotNET-Core-SDK-2.2.101.eb
	new file:   e/ELPA/ELPA-2016.11.001.pre-intel-2017a.eb
	new file:   e/ELPA/ELPA-2017.11.001-intel-2017a.eb
	new file:   h/HDF5/HDF5-1.10.2-intel-2017a.eb
	new file:   l/libxc/libxc-4.2.3-intel-2017a.eb
	new file:   p/phonopy/phonopy-1.14.2-Py-3.6.eb
	modified:   q/QuantumESPRESSO/QuantumESPRESSO-6.3-intel-2017a.eb
	new file:   q/QuantumESPRESSO/QuantumESPRESSO-6.3-intel-2017a.eb.old
	modified:   q/QuantumESPRESSO/QuantumESPRESSO-6.3_drop_LIBS_before_configure_of_fox.patch
	new file:   q/QuantumESPRESSO/QuantumESPRESSO-6.3_drop_LIBS_before_configure_of_fox.patch.old
	new file:   v/VASP/VASP-5.4.4-intel-2017c-mkl=cluster-LONGCHAR.eb
parent ac5431f5
Pipeline #5540 failed with stage
in 14 seconds
easyblock = 'Tarball'
# note: only works on recent OSs, required sufficiently recent glibc (2.14
# or newer)
name = 'dotNET-Core-Runtime'
version = '2.2.0'
homepage = 'https://www.microsoft.com/net/'
description = """.NET is a free, cross-platform, open source developer platform for building many different types
of applications."""
toolchain = {'name': 'dummy', 'version': ''}
source_urls = ['https://download.visualstudio.microsoft.com/download/pr/1057e14e-16cc-410b-80a4-5c2420c8359c/004dc3ce8255475d4723de9a011ac513/']
sources = ['dotnet-runtime-%(version)s-linux-x64.tar.gz']
dependencies = [
('libunwind', '1.2'),
]
sanity_check_paths = {
'files': ['dotnet'],
'dirs': ['shared/Microsoft.NETCore.App/%(version)s'],
}
modextrapaths = {'PATH': ['']}
moduleclass = 'lang'
easyblock = 'Tarball'
# note: only works on recent OSs, required sufficiently recent glibc (2.14
# or newer)
name = 'dotNET-Core-SDK'
version = '2.2.101'
homepage = 'https://www.microsoft.com/net/'
description = """.NET is a free, cross-platform, open source developer platform for building many different types
of applications."""
toolchain = {'name': 'dummy', 'version': ''}
source_urls = ['https://download.visualstudio.microsoft.com/download/pr/80e1d007-d6f0-402f-b047-779464dd989b/9ae5e2df9aa166b720bdb92d19977044']
sources = ['dotnet-sdk-%(version)s-linux-x64.tar.gz']
dependencies = [('libunwind', '1.2')]
sanity_check_paths = {
'files': ['dotnet'],
'dirs': ['sdk'],
}
modextrapaths = {'PATH': ['']}
moduleclass = 'lang'
##
# This file is an EasyBuild reciPY as per https://github.com/easybuilders/easybuild
#
# Authors:: Inge Gutheil <i.gutheil@fz-juelich.de>, Alan O'Cais <a.ocais@fz-juelich.de>
# License:: MIT/GPL
# $Id$
#
##
easyblock = 'ConfigureMake'
name = 'ELPA'
version = '2016.11.001.pre'
homepage = 'http://elpa.mpcdf.mpg.de'
description = """Eigenvalue SoLvers for Petaflop-Applications ."""
toolchain = {'name': 'intel', 'version': '2017a'}
toolchainopts = {'usempi': True}
source_urls = ['http://elpa.mpcdf.mpg.de/html/Releases/%(version)s/']
sources = [SOURCELOWER_TAR_GZ]
patches = [
'%(name)s-%(version)s_install-libelpatest.patch',
]
checksums = [
'69b67f0f6faaa2b3b5fd848127b632be32771636d2ad04583c5269d550956f92', # elpa-2016.11.001.pre.tar.gz
# ELPA-2016.11.001.pre_install-libelpatest.patch
'aaee4cbe02a2f2e0b6fa76c1503d049e2958d949f4be13dfa8be9c60043a328b',
]
builddependencies = [
('Autotools', '20180311', '', True),
]
preconfigopts = 'autoreconf && '
common_configopts = 'FCFLAGS="-I$EBROOTIMKL/mkl/include/intel64/lp64 $FCFLAGS" '
common_configopts += 'LIBS="$LIBSCALAPACK" '
configopts = [
common_configopts + '--enable-openmp ',
common_configopts, # Default version last, so we can get the normal config.h/config-f90.h installed afterwards.
]
# Autotools 20180311 makes configure create some files that causes problem
# Remove them.
prebuildopts = 'make clean && '
buildopts = ' V=1 '
postinstallcmds = [
'cp config.h config-f90.h %(installdir)s/share/doc/elpa/examples',
# The include files and Fortran module files are identical with and
# without openmp.
'ln -s elpa-%(version)s/elpa %(installdir)s/include',
'ln -s elpa-%(version)s/modules %(installdir)s/include',
]
sanity_check_paths = {
'files': ['lib/libelpa.a', 'lib/libelpa.%s' % SHLIB_EXT, 'lib/libelpa_openmp.a',
'lib/libelpa_openmp.%s' % SHLIB_EXT, 'lib/libelpatest.a', 'lib/libelpatest.%s' % SHLIB_EXT,
'lib/libelpatest_openmp.a', 'lib/libelpatest_openmp.%s' % SHLIB_EXT, 'share/doc/elpa/examples/config.h',
'share/doc/elpa/examples/config-f90.h'],
'dirs': ['bin', 'include/elpa-%(version)s/elpa', 'include/elpa-%(version)s/modules', 'lib/pkgconfig'],
}
moduleclass = 'math'
##
# This file is an EasyBuild reciPY as per https://github.com/easybuilders/easybuild
#
# Authors:: Inge Gutheil <i.gutheil@fz-juelich.de>, Alan O'Cais <a.ocais@fz-juelich.de>
# License:: MIT/GPL
# $Id$
#
##
easyblock = 'ConfigureMake'
name = 'ELPA'
version = '2017.11.001'
homepage = 'http://elpa.rzg.mpg.de'
description = """Eigenvalue SoLvers for Petaflop-Applications ."""
toolchain = {'name': 'intel', 'version': '2017a'}
toolchainopts = {'usempi': True}
source_urls = ['http://elpa.mpcdf.mpg.de/html/Releases/%(version)s/']
sources = [SOURCELOWER_TAR_GZ]
builddependencies = [
('Autotools', '20180311', '', True),
]
preconfigopts = 'autoreconf && '
common_configopts = 'FCFLAGS="-I$EBROOTIMKL/mkl/include/intel64/lp64 $FCFLAGS" '
common_configopts += 'LIBS="$LIBSCALAPACK" '
configopts = [
common_configopts + '--enable-openmp ',
common_configopts, # Default version last, so we can get the normal config.h/config-f90.h installed afterwards.
]
buildopts = ' V=1 '
sanity_check_paths = {
'files': ['lib/libelpa.a', 'lib/libelpa.%s' % SHLIB_EXT, 'lib/libelpa_openmp.a',
'lib/libelpa_openmp.%s' % SHLIB_EXT],
'dirs': ['bin', 'include/elpa-%(version)s/elpa', 'include/elpa-%(version)s/modules', 'lib/pkgconfig'],
}
moduleclass = 'math'
# IT4Innovations
name = 'HDF5'
version = '1.10.2'
homepage = 'https://portal.hdfgroup.org/display/support'
description = """HDF5 is a data model, library, and file format for storing and managing data.
It supports an unlimited variety of datatypes, and is designed for flexible
and efficient I/O and for high volume and complex data."""
toolchain = {'name': 'intel', 'version': '2017a'}
toolchainopts = {'pic': True, 'usempi': True}
source_urls = ['https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-%(version_major_minor)s/hdf5-%(version)s/src']
sources = [SOURCELOWER_TAR_GZ]
checksums = ['bfec1be8c366965a99812cf02ddc97e4b708c1754fccba5414d4adccdc073866']
dependencies = [
('zlib', '1.2.11', '', True),
('Szip', '2.1', '', True),
]
moduleclass = 'data'
easyblock = 'ConfigureMake'
name = 'libxc'
version = '4.2.3'
homepage = 'http://www.tddft.org/programs/octopus/wiki/index.php/Libxc'
description = """Libxc is a library of exchange-correlation functionals for density-functional theory.
The aim is to provide a portable, well tested and reliable set of exchange and correlation functionals."""
toolchain = {'name': 'intel', 'version': '2017a'}
source_urls = ['http://www.tddft.org/programs/octopus/down.php?file=libxc/%(version)s/']
sources = [SOURCE_TAR_GZ]
checksums = ['02e49e9ba7d21d18df17e9e57eae861e6ce05e65e966e1e832475aa09e344256']
configopts = '--enable-static --enable-shared --enable-fortran'
runtest = 'check'
sanity_check_paths = {
'files': ['lib/libxc%s.%s' % (x, y) for x in ['', 'f90'] for y in ['a', SHLIB_EXT]],
'dirs': ['include'],
}
parallel = 1
moduleclass = 'chem'
# IT4Innovations 2018
easyblock = 'PythonPackage'
name = 'phonopy'
version = '1.14.2'
homepage = 'https://atztogo.github.io/phonopy'
description = """Phonopy is an open source package of phonon calculations based on the supercell approach."""
toolchain = {'name': 'Py', 'version': '3.6'}
source_urls = [PYPI_SOURCE]
sources = [SOURCE_TAR_GZ]
dependencies = [
('matplotlib', '2.1.1'),
('lxml', '4.1.1'),
('PyYAML', '3.12'),
('numpy', '1.13.3'),
('h5py', '2.7.1'),
('scipy', '1.0.0')
]
moduleclass = 'python'
......@@ -3,37 +3,54 @@
name = 'QuantumESPRESSO'
version = '6.3'
homepage = 'http://www.pwscf.org/'
homepage = 'https://www.quantum-espresso.org'
description = """Quantum ESPRESSO is an integrated suite of computer codes
for electronic-structure calculations and materials modeling at the nanoscale.
It is based on density-functional theory, plane waves, and pseudopotentials
(both norm-conserving and ultrasoft)."""
(both norm-conserving and ultrasoft).
"""
toolchain = {'name': 'intel', 'version': '2017a'}
toolchainopts = {'usempi': True, 'openmp': True}
# major part of this list was determined from espresso/install/plugins_list
# - There is currently no plumed version that works for QME 6.3
# - Yambo is better to install outside of QM-E, there are problems
# building it with openmp turned on and the intel toolchain and there is
# no added benefit to build it inside QM-E
# - Want is never installed in bin/ (since it first shows up in 4.2) so
# don't bother building it here.
source_urls = [
'https://github.com/QEF/q-e/releases/download/qe-%(version)s/',
'https://github.com/dceresoli/qe-gipaw/archive/',
'http://www.wannier.org/code/', # wannier90-2.1.0.tar.gz
]
sources = [
'qe-%(version)s.tar.gz',
{'filename': 'qe-gipaw-%(version)s.tar.gz', 'download_filename': '%(version)s.tar.gz', 'source_urls': ['https://github.com/dceresoli/qe-gipaw/archive/']},
{'filename': 'wannier90-2.1.0.tar.gz', 'source_urls': ['http://www.wannier.org/code/']},
{'filename': 'qe-gipaw-%(version)s.tar.gz', 'download_filename': '%(version)s.tar.gz'},
'wannier90-2.1.0.tar.gz',
]
# The old qe-forge archive doesn't exist any longer.
# This easyconfig is for those who have the old qe-forge tar file downloaded.
# The qe tar file from github for 6.2 has a different top level directory name
# than the old qe-forge tarfile did and the easyblock expects the old name.
# Old download was
# wget http://qe-forge.org/gf/download/frsrelease/244/1114/qe-6.2.tar.gz
source_urls = [
'https://github.com/QEF/q-e/archive/', # qe
patches = [
'%(name)s-%(version)s_drop_LIBS_before_configure_of_fox.patch'
]
checksums = [
'5d15f7cbb30ccb2e2e6722bc1cdf10a3aae909ae786654b0990068ed1846ad65', # qe-6.3.tar.gz
'090edfcc186047a12c596ec13fdb29c187ab33d91a44c08371f23e779bb15f1e', # qe-gipaw-6.3.tar.gz
'ee90108d4bc4aa6a1cf16d72abebcb3087cf6c1007d22dda269eb7e7076bddca', # wannier90-2.1.0.tar.gz
# QuantumESPRESSO-6.3_drop_LIBS_before_configure_of_fox.patch
'714fef8be920a5a7c6afe81a7364978c00d76d6d39f79b8b18862c1598ea6af3',
]
patches = [
'%(name)s-%(version)s_drop_LIBS_before_configure_of_fox.patch',
dependencies = [
('HDF5', '1.10.2'),
('ELPA', '2016.11.001.pre'),
('libxc', '4.2.3'),
]
buildopts = 'all w90 gipaw xspectra pwall ph epw'
# The third party packages should be installed separately and added as
# dependencies. The exception is w90, which is force built, and gipaw
# which depends on qe source
buildopts = 'all gwl xspectra couple epw gipaw w90'
# parallel build tends to fail
parallel = 1
......
# IT4Innovations
name = 'QuantumESPRESSO'
version = '6.3'
homepage = 'http://www.pwscf.org/'
description = """Quantum ESPRESSO is an integrated suite of computer codes
for electronic-structure calculations and materials modeling at the nanoscale.
It is based on density-functional theory, plane waves, and pseudopotentials
(both norm-conserving and ultrasoft)."""
toolchain = {'name': 'intel', 'version': '2017a'}
toolchainopts = {'usempi': True, 'openmp': True}
sources = [
'qe-%(version)s.tar.gz',
{'filename': 'qe-gipaw-%(version)s.tar.gz', 'download_filename': '%(version)s.tar.gz', 'source_urls': ['https://github.com/dceresoli/qe-gipaw/archive/']},
{'filename': 'wannier90-2.1.0.tar.gz', 'source_urls': ['http://www.wannier.org/code/']},
]
# The old qe-forge archive doesn't exist any longer.
# This easyconfig is for those who have the old qe-forge tar file downloaded.
# The qe tar file from github for 6.2 has a different top level directory name
# than the old qe-forge tarfile did and the easyblock expects the old name.
# Old download was
# wget http://qe-forge.org/gf/download/frsrelease/244/1114/qe-6.2.tar.gz
source_urls = [
'https://github.com/QEF/q-e/archive/', # qe
]
patches = [
'%(name)s-%(version)s_drop_LIBS_before_configure_of_fox.patch',
]
buildopts = 'all w90 gipaw xspectra pwall ph epw'
# parallel build tends to fail
parallel = 1
moduleclass = 'chem'
--- q-e-qe-6.3/install/extlibs_makefile.orig 2018-12-12 10:34:41.129044224 +0100
+++ q-e-qe-6.3/install/extlibs_makefile 2018-12-12 10:35:34.600005304 +0100
# Must drop LIBS before running configure of FoX.
# Otherwise configure will fail early.
#
# Åke Sandgren, 20180712
diff -ru qe-6.3.orig/install/extlibs_makefile qe-6.3/install/extlibs_makefile
--- qe-6.3.orig/install/extlibs_makefile 2018-07-06 17:36:48.000000000 +0200
+++ qe-6.3/install/extlibs_makefile 2018-07-13 08:38:25.698151677 +0200
@@ -89,7 +89,7 @@
mkdir ../FoX; \
(gzip -dc ../archive/fox.tgz | (cd ../FoX; tar -xvf -)); \
......
--- q-e-qe-6.3/install/extlibs_makefile.orig 2018-12-12 10:34:41.129044224 +0100
+++ q-e-qe-6.3/install/extlibs_makefile 2018-12-12 10:35:34.600005304 +0100
@@ -89,7 +89,7 @@
mkdir ../FoX; \
(gzip -dc ../archive/fox.tgz | (cd ../FoX; tar -xvf -)); \
cd ../FoX/fox/; export FC=$(F90); export FCFLAGS="$(FOX_FLAGS)"; \
- ./configure --prefix=$(TOPDIR)/FoX ;\
+ unset LIBS; ./configure --prefix=$(TOPDIR)/FoX ;\
$(MAKE) install; cd ../; rm -fr fox;fi
# ELPA
libelpa : libelpa_$(ELPA_LIBS_SWITCH)
# IT4Innovations 2018
easyblock = 'MakeCp'
name = 'VASP'
version = '5.4.4'
versionsuffix = '-mkl=cluster-LONGCHAR'
homepage = 'http://www.vasp.at'
description = """The Vienna Ab initio Simulation Package (VASP) is a computer program for atomic scale
materials modelling, e.g. electronic structure calculations and quantum-mechanical molecular dynamics,
from first principles.
To use VASP, You need academic licenses from University of Wiena. Follow the instructions https://www.vasp.at/index.php/faqs.
Then send us please a list of authorized users and their ID for which you need this access. Please use only http://support.it4i.cz/rt. We are responsible to verify your licenses. After succesfull verification You will be granted to use VASP in our enviroment."""
toolchain = {'name': 'intel', 'version': '2017c'}
toolchainopts = {'pic': True, 'usempi': True}
# Vasp is proprietary software, see http://www.vasp.at/index.php/faqs on
# how to get access to the code
sources = ['%(namelower)s.%(version)s.tar.gz']
#checksums = ['8ac646b108f974371eef398973373bf6']
dependencies = [
('zlib', '1.2.11', '', True),
]
prebuildopts = 'cp arch/makefile.include.linux_intel ./makefile.include && '
# path to libfftw3xf_intel.a is hardcoded in makefile.include
prebuildopts += 'sed -i "s|\$(MKLROOT)/interfaces/fftw3xf|\$(FFTW_LIB_DIR)|" makefile.include && '
# remove mkl flag to prevent mixing dynamic libs with the static libs in
# LIBBLACS/SCALAPACK
prebuildopts += 'sed -i "s|-mkl=sequential|-mkl=cluster|" makefile.include && '
# OFLAG = -O2 -xAVX
prebuildopts += 'sed -i "s|OFLAG = -O2|OFLAG = -O3 -xAVX|" makefile.include && '
# objects add MKLROOT
prebuildopts += 'sed -i "s|OBJECTS = fftmpiw.o fftmpi_map.o fft3dlib.o fftw3d.o|OBJECTS = fftmpiw.o fftmpi_map.o fft3dlib.o fftw3d.o \$\(MKLROOT\)/lib/intel64_lin/libfftw3xf_intel.a|" makefile.include && '
# VASP uses LIBS as a list of folders
prebuildopts += 'unset LIBS && '
#prebuildopts += 'exit 1'
buildopts = 'all BLACS="$LIBBLACS" SCALAPACK="$LIBSCALAPACK"'
parallel = 1
files_to_copy = [(['bin/vasp_std', 'bin/vasp_gam', 'bin/vasp_ncl'], 'bin')]
sanity_check_paths = {
'files': ['bin/vasp_std', 'bin/vasp_gam', 'bin/vasp_ncl'],
'dirs': []
}
moduleclass = 'phys'
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment