Commit 9f94e14b authored by easybuild's avatar easybuild Committed by Lukáš Krupčík

remove EasyBuild/* test

parent dbc85615
easyblock = 'EB_EasyBuildMeta'
name = 'EasyBuild'
version = '3.1.1'
versionsuffix = 'test-python'
homepage = 'http://hpcugent.github.com/easybuild/'
description = """EasyBuild is a software build and installation framework
written in Python that allows you to install software in a structured,
repeatable and robust way."""
toolchain = {'name': 'dummy', 'version': 'dummy'}
source_urls = [
# vsc-install
'https://pypi.python.org/packages/ef/c7/640c6d791ba452321c0d1371b6626486bb495e0645bb896d33c78a09f810',
# vsc-base
'https://pypi.python.org/packages/da/90/ee40b1a6a5bfed24139042c737500a9b45db0373a6735e76481fc860fe37',
# easybuild-framework
'https://pypi.python.org/packages/f2/19/1c79b1ad24f0004e9507f12d4222367611f42ac479abd6315a50a23c52f5',
# easybuild-easyblocks
'https://pypi.python.org/packages/87/aa/2a19f05c78dd2550f7bd42ef0964b9c51c5626c1e715c2ee0a4f778780b8',
# easybuild-easyconfigs
'https://pypi.python.org/packages/e6/68/5e977f549bf04b8cd87cdc5179d8b36c1eb971cfe3c43f98053f2dbe9c64',
]
# order matters a lot, to avoid having dependencies auto-resolved (--no-deps easy_install option doesn't work?)
sources = [
'vsc-install-0.10.25.tar.gz',
'vsc-base-2.5.7.tar.gz',
'easybuild-framework-%(version)s.tar.gz',
'easybuild-easyblocks-%(version)s.tar.gz',
'easybuild-easyconfigs-%(version)s.tar.gz',
]
# EasyBuild is a (set of) Python packages, so it depends on Python
# usually, we want to use the system Python, so no actual Python dependency is listed
allow_system_deps = [('Python', SYS_PYTHON_VERSION)]
moduleclass = 'tools'
easyblock = 'EB_EasyBuildMeta'
name = 'EasyBuild'
version = '3.1.1'
versionsuffix = '-test-python2'
homepage = 'http://hpcugent.github.com/easybuild/'
description = """EasyBuild is a software build and installation framework
written in Python that allows you to install software in a structured,
repeatable and robust way."""
toolchain = {'name': 'dummy', 'version': 'dummy'}
source_urls = [
# vsc-install
'https://pypi.python.org/packages/ef/c7/640c6d791ba452321c0d1371b6626486bb495e0645bb896d33c78a09f810',
# vsc-base
'https://pypi.python.org/packages/da/90/ee40b1a6a5bfed24139042c737500a9b45db0373a6735e76481fc860fe37',
# easybuild-framework
'https://pypi.python.org/packages/f2/19/1c79b1ad24f0004e9507f12d4222367611f42ac479abd6315a50a23c52f5',
# easybuild-easyblocks
'https://pypi.python.org/packages/87/aa/2a19f05c78dd2550f7bd42ef0964b9c51c5626c1e715c2ee0a4f778780b8',
# easybuild-easyconfigs
'https://pypi.python.org/packages/e6/68/5e977f549bf04b8cd87cdc5179d8b36c1eb971cfe3c43f98053f2dbe9c64',
]
# order matters a lot, to avoid having dependencies auto-resolved (--no-deps easy_install option doesn't work?)
sources = [
'vsc-install-0.10.25.tar.gz',
'vsc-base-2.5.7.tar.gz',
'easybuild-framework-%(version)s.tar.gz',
'easybuild-easyblocks-%(version)s.tar.gz',
'easybuild-easyconfigs-%(version)s.tar.gz',
]
# EasyBuild is a (set of) Python packages, so it depends on Python
# usually, we want to use the system Python, so no actual Python dependency is listed
allow_system_deps = [('Python', SYS_PYTHON_VERSION)]
moduleclass = 'tools'
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment