Commit a02adfba authored by Lukáš Krupčík's avatar Lukáš Krupčík

new file: b/Blender/Blender-2.81-intel-2017c-Py-3.7.eb

	new file:   g/GDL/GDL-0.9.9-intel-2017c.eb
	new file:   g/GSL/GSL-2.5.eb
	new file:   o/OpenEXR/OpenEXR-2.3.0-intel-2017c.eb
	new file:   o/OpenImageIO/OpenImageIO-2.0.12-intel-2017c.eb
	new file:   p/PLplot/PLplot-5.11.1.eb
	new file:   p/Py/Py-3.7.eb
	new file:   p/Python/Python-3.7.3-GCCcore-6.3.0-base.eb
parent a85d0f01
Pipeline #10100 passed with stage
in 20 seconds
# IT4Innovations 2019
easyblock = 'CMakeMake'
name = 'Blender'
version = '2.81'
versionsuffix = '-Py-3.7'
homepage = 'https://www.blender.org/'
description = """Blender is the free and open source 3D creation suite. It supports
the entirety of the 3D pipeline-modeling, rigging, animation, simulation, rendering,
compositing and motion tracking, even video editing and game creation."""
toolchain = {'name': 'intel', 'version': '2017c'}
source_urls = ['https://download.blender.org/source/']
sources = [SOURCELOWER_TAR_XZ]
checksums = ['ca429da7bf0f1e9ce39c915288cfa2b76ed7ec36885139c4d7c18912840337df']
# disable SSE detection to give EasyBuild full control over optimization compiler flags being used
configopts = '-DWITH_CPU_SSE=OFF -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" '
# these are needed until extra dependencies are added for them to work
configopts += '-DWITH_INSTALL_PORTABLE=OFF '
configopts += '-DWITH_BUILDINFO=OFF '
configopts += '-DWITH_GAMEENGINE=OFF '
configopts += '-DWITH_SYSTEM_GLEW=OFF '
# Python paths
configopts += '-DPYTHON_VERSION=3.7 PYTHON_LIBRARY=${EBROOTPYTHON}/lib/libpython3.7m.so '
configopts += '-DPYTHON_INCLUDE_DIR=${EBROOTPYTHON}/include/python3.7m '
configopts += '-DOPENEXR_INCLUDE_DIR=$EBROOTOPENEXR/include '
dependencies = [
('Py', '3.7', '', True),
# ('SciPy-bundle', '2019.10', versionsuffix),
('Boost', '1.68.0'),
('libjpeg-turbo', '2.0.2', '', True),
('zlib', '1.2.11', '', True),
('X11', '20190311', '', True),
('Mesa', '18.3.1', '', True),
('libGLU', '9.0.0', '', True),
('OpenImageIO', '2.0.12'), # required for cycles render engine
]
builddependencies = [('CMake', '3.16.0', '-rc3', True)]
separate_build_dir = 'True'
# use Intel software rasterizer by default (no GPU hardware acceleration)
modextravars = {'GALLIUM_DRIVER': 'swr'}
sanity_check_paths = {
'files': ['bin/blender'],
'dirs': []
}
moduleclass = 'vis'
# IT4Innovations 2019
easyblock = 'CMakeMake'
name = 'GDL'
version = '0.9.9'
homepage = 'https://github.com/gnudatalanguage/gdl'
description = """GDL is a free/libre/open source incremental compiler compatible
with IDL (Interactive Data Language) and to some extent with PV-WAVE. Together
with its library routines it serves as a tool for data analysis and visualization
in such disciplines as astronomy, geosciences and medical imaging. GDL development
had been started by Marc Schellens back in early noughties and has since continued
with help of a team of maintainers, developers, packagers and thanks to feedback from users."""
toolchain = {'name': 'intel', 'version': '2017c'}
toolchainopts = {'pic': True}
source_urls = ['https://github.com/gnudatalanguage/gdl/archive/']
sources = ['v%(version)s.tar.gz']
builddependencies = [
('CMake', '3.16.0', '-rc3', True)
]
dependencies = [
('libreadline', '8.0', '', True),
('GSL', '2.5'),
('ncurses', '6.1', '', True),
('zlib', '1.2.11', '', True),
('netCDF', '4.6.2'),
('HDF5', '1.10.5'),
('FFTW', '3.3.8'),
('PROJ_4', '4.9.2', '', True),
('expat', '2.2.6', '', True),
('numpy', '1.16.3', '-Py-2.7', True),
('Eigen', '3.3.7', '', True),
]
sanity_check_paths = {
'files': [],
'dirs': ['include/glm/'],
}
moduleclass = 'lib'
# IT4Innovations 2019
easyblock = 'ConfigureMake'
name = 'GSL'
version = '2.5'
homepage = 'http://www.gnu.org/software/gsl/'
description = """The GNU Scientific Library (GSL) is a numerical library for C and C++ programmers.
The library provides a wide range of mathematical routines such as random number generators, special functions
and least-squares fitting."""
toolchain = SYSTEM
toolchainopts = {'unroll': True, 'pic': True}
source_urls = [GNU_SOURCE]
sources = [SOURCELOWER_TAR_GZ]
checksums = ['0460ad7c2542caaddc6729762952d345374784100223995eb14d614861f2258d']
sanity_check_paths = {
'files': ['bin/%s' % x for x in ['gsl-config', 'gsl-histogram', 'gsl-randist']] +
['include/gsl/gsl_types.h'] +
['lib/lib%s.%s' % (x, SHLIB_EXT) for x in ['gsl', 'gslcblas']],
'dirs': [],
}
moduleclass = 'numlib'
# IT4Innovations 2019
easyblock = 'CMakeMake'
name = 'OpenEXR'
version = '2.3.0'
homepage = 'http://www.openexr.com/'
description = """OpenEXR is a high dynamic-range (HDR) image file format developed by Industrial Light & Magic
for use in computer imaging applications"""
toolchain = {'name': 'intel', 'version': '2017c'}
source_urls = ['https://github.com/openexr/openexr/archive/']
sources = ['v%(version)s.tar.gz']
checksums = ['8243b7de12b52239fe9235a6aeb4e35ead2247833e4fbc41541774b222717933']
builddependencies = [('CMake', '3.16.0', '-rc3', True)]
configopts = '-DOPENEXR_BUILD_PYTHON_LIBS=OFF'
sanity_check_paths = {
'files': ['lib/lib%s-%%(version_major)s_%%(version_minor)s.%s' % (x, SHLIB_EXT) for x in
['Half', 'Iex', 'IexMath', 'IlmImf', 'IlmImfUtil', 'IlmThread', 'Imath']] +
['bin/exr%s' % x for x in
['envmap', 'header', 'makepreview', 'maketiled', 'multipart', 'multiview', 'stdattr']],
'dirs': ['include/OpenEXR', 'share'],
}
moduleclass = 'vis'
# IT4Innovations 2019
easyblock = 'CMakeMake'
name = 'OpenImageIO'
version = '2.0.12'
homepage = 'https://openimageio.org/'
description = """OpenImageIO is a library for reading and writing images, and a bunch of related classes, utilities,
and applications."""
toolchain = {'name': 'intel', 'version': '2017c'}
source_urls = ['https://github.com/OpenImageIO/oiio/archive/']
sources = ['Release-%(version)s.tar.gz']
checksums = ['930a142c9cabbbc3b249577083c97e9f0407cc8cbf933144f3a3ed0f3ec9cfe0']
dependencies = [
('Boost', '1.68.0'),
('libjpeg-turbo', '2.0.2', '', True),
('libpng', '1.6.34', '', True),
('LibTIFF', '4.0.7', '', True),
('OpenEXR', '2.3.0'),
('freetype', '2.9.1', '', True),
('zlib', '1.2.11', '', True),
]
builddependencies = [('CMake', '3.16.0', '-rc3', True)]
separate_build_dir = True
configopts = '-DSTOP_ON_WARNING=OFF -DUSE_PYTHON=OFF'
sanity_check_paths = {
'files': ['bin/oiiotool', 'lib/libOpenImageIO.%s' % SHLIB_EXT, 'lib/libOpenImageIO_Util.%s' % SHLIB_EXT],
'dirs': ['include/OpenImageIO', 'share'],
}
moduleclass = 'lib'
# IT4Innovations 2019
easyblock = 'CMakeMake'
name = 'PLplot'
version = '5.11.1'
#versionsuffix = '-Java-%(javaver)s-Python-%(pyver)s'
homepage = 'http://plplot.sourceforge.net'
description = """PLplot is a cross-platform software package for creating scientific plots whose (UTF-8) plot symbols
and text are limited in practice only by what Unicode-aware system fonts are installed on a user's computer."""
toolchain = SYSTEM
toolchainopts = {'pic': True}
source_urls = [SOURCEFORGE_SOURCE]
sources = [SOURCELOWER_TAR_GZ]
builddependencies = [
('CMake', '3.16.0', '-rc3'),
# ('SWIG', '3.0.10', '-Python-%(pyver)s-PCRE-8.39'),
# ('libtool', '2.4.6'),
]
dependencies = [
('zlib', '1.2.11'),
# ('Java', '1.7.0_80', '', True),
# ('Python', '2.7.12'),
# ('Perl', '5.24.0'),
# ('cairo', '1.14.6'),
# ('expat', '2.2.0'),
# ('GLib', '2.49.5'),
# ('X11', '20160819'),
# ('Pango', '1.40.3'),
# ('pixman', '0.34.0'),
# ('Tcl', '8.6.5'),
# ('Tk', '8.6.5'),
]
separate_build_dir = True
#modextrapaths = {'PYTHONPATH': 'lib/python%(pyshortver)s/site-packages'}
sanity_check_paths = {
'files': ['lib/libplplot.so', 'lib/pkgconfig/plplot-f95.pc'],
'dirs': ['bin', 'include/plplot', 'lib/fortran/modules/plplot', 'lib/pkgconfig', 'share/man/man1'],
}
moduleclass = 'vis'
# IT4Innovations 2019
easyblock = "Toolchain"
name = 'Py'
version = '3.7'
homepage = 'https://www.python.org'
description = """Python 3.6 toolchain"""
toolchain = SYSTEM
dependencies = [
('Python', '3.7.3', '-base', ('GCCcore', '6.3.0')),
('GCC', '6.3.0-2.27'),
]
moduleclass = 'toolchain'
# IT4Innovations 2019
name = 'Python'
version = '3.7.3'
versionsuffix = '-base'
homepage = 'http://python.org/'
description = """Python is a programming language that lets you work more quickly and integrate your systems
more effectively."""
toolchain = {'name': 'GCCcore', 'version': '6.3.0'}
toolchainopts = {'pic': True}
source_urls = ['http://www.python.org/ftp/%(namelower)s/%(version)s/']
sources = [SOURCE_TGZ]
builddependencies = [('binutils', '2.27')]
dependencies = [
('bzip2', '1.0.6', '', True), # required for bz2 package in Python stdlib
('zlib', '1.2.11', '', True),
('libreadline', '8.0', '', True),
('ncurses', '6.1', '', True),
('SQLite', '3.27.2', '', True),
('XZ', '5.2.4', '', True),
('GMP', '6.1.2', '', True), # required for pycrypto
('libffi', '3.2.1', '', True), # required for cryptography
# OS dependency should be preferred if the os version is more recent then this version,
# it's nice to have an up to date openssl for security reasons
# Python 3.7 requires OpenSSL >= 1.0.2, uncomment line below if OS version is too old (e.g. CentOS 6)
# ('OpenSSL', '1.1.0j'),
]
#osdependencies = [('openssl-devel', 'libssl-dev', 'libopenssl-devel')]
# symlink 'pip' command to 'pip3' that is included with Python installation
# required so we can update pip to version included in extensions, using pip
installopts = " && ln -s %(installdir)s/bin/pip3 %(installdir)s/bin/pip"
#exts_default_options = {
# 'download_dep_fail': True,
# 'use_pip': True,
#}
# order is important!
# package versions updated Mar 15th 2019
#exts_list = [
# ('pip', '19.0.3', {
# 'source_urls': ['https://pypi.python.org/packages/source/p/pip/'],
# 'checksums': ['6e6f197a1abfb45118dbb878b5c859a0edbdd33fd250100bc015b67fded4b9f2'],
# # don't use --ignore-installed, i.e. let pip remove older pip version included with Python
# 'pip_ignore_installed': False,
# }),
# ('setuptools', '40.8.0', {
# 'source_tmpl': '%(name)s-%(version)s.zip',
# 'source_urls': ['https://pypi.python.org/packages/source/s/setuptools/'],
# 'checksums': ['6e4eec90337e849ade7103723b9a99631c1f0d19990d6e8412dc42f5ae8b304d'],
# # don't use --ignore-installed, i.e. let pip remove older setuptools version included with Python
# 'pip_ignore_installed': False,
# }),
# ('wheel', '0.33.1', {
# 'source_urls': ['https://pypi.python.org/packages/source/w/wheel'],
# 'checksums': ['66a8fd76f28977bb664b098372daef2b27f60dc4d1688cfab7b37a09448f0e9d'],
# })
#]
moduleclass = 'lang'
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment