Commit b4b3ae05 authored by Lukáš Krupčík's avatar Lukáš Krupčík

Merge branch 'it4i-salomon'

parents d6468223 80593caa
Pipeline #6231 passed with stage
in 24 seconds
# IT4Innovations 2019
name = 'Hypre'
version = '2.15.1'
homepage = "https://computation.llnl.gov/casc/linear_solvers/sls_hypre.html"
description = """Hypre is a library for solving large, sparse linear systems of equations on massively parallel computers.
The problems of interest arise in the simulation codes being developed at LLNL and elsewhere
to study physical phenomena in the defense, environmental, energy, and biological sciences."""
toolchain = {'name': 'foss', 'version': '2017b'}
toolchainopts = {'pic': True}
source_urls = ['https://github.com/LLNL/hypre/archive/']
sources = ['v%(version)s.tar.gz']
start_dir = 'src'
sanity_check_paths = {
'files': ['lib/libHYPRE.a'],
'dirs': ['include']
}
moduleclass = 'numlib'
# IT4Innovations 2019
name = 'Hypre'
version = '2.15.1'
homepage = "https://computation.llnl.gov/casc/linear_solvers/sls_hypre.html"
description = """Hypre is a library for solving large, sparse linear systems of equations on massively parallel computers.
The problems of interest arise in the simulation codes being developed at LLNL and elsewhere
to study physical phenomena in the defense, environmental, energy, and biological sciences."""
toolchain = {'name': 'intel', 'version': '2017a'}
toolchainopts = {'pic': True}
source_urls = ['https://github.com/LLNL/hypre/archive/']
sources = ['v%(version)s.tar.gz']
start_dir = 'src'
sanity_check_paths = {
'files': ['lib/libHYPRE.a'],
'dirs': ['include']
}
moduleclass = 'numlib'
# This is an easyconfig file for EasyBuild, see
# This is an easyconfig file for EasyBuild, see
# http://hpcugent.github.io/easybuild
easyblock = "Toolchain"
......
# IT4Innovations 2019
easyblock = "Toolchain"
name = 'iompi'
version = '2017c'
homepage = 'http://software.intel.com/en-us/intel-cluster-toolkit-compiler/'
description = """Intel C/C++ and Fortran compilers, alongside Open MPI."""
toolchain = {'name': 'dummy', 'version': 'dummy'}
compver = '2017.5.239'
compversuff = '-GCC-6.3.0-2.27'
dependencies = [
('icc', compver, compversuff),
('ifort', compver, compversuff),
('OpenMPI', '2.1.1', compversuff, True),
]
moduleclass = 'toolchain'
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment