requires.txt is not mandatory for metadata generator

6 jobs for extras in 4 minutes and 25 seconds
Status Job ID Name Coverage
  Test
passed #36365
mdcheck

00:00:14

passed #36366
pycodestyle

00:00:13

passed #36367
pylint

00:00:21

 
  Build
passed #36368
build

00:01:38

 
  Check
passed #36369
Install test

00:02:24

failed #36370
versioncheck

00:00:16

 
Name Stage Failure
failed
versioncheck Check

Installed /builds/sccs/pip-deps/.eggs/mustache-0.1.4-py2.7.egg
0.0.3
$ export BUILD_VERSION="$(python setup.py --version)"
$ export PUBLISHED_VERSION="$(pip install pipdeps== 2>&1 | grep -oE "\(from versions: .*)" | sed "s/(from versions: //" | sed "s/)//" | tr ", " "\n" | tail -n1)"
$ CMP_VERSION="$(cmp-version $BUILD_VERSION $PUBLISHED_VERSION)"
$ if [ $CMP_VERSION -eq 1 ]; then true; else echo 'Git tag is older/same version as module already available from public pypi repository. Please run git tag -a <version> -m "<version>"'; false; fi
Git tag is older/same version as module already available from public pypi repository. Please run git tag -a <version> -m "<version>"
ERROR: Job failed: exit code 1