Commit 4b543cb3 authored by David Hrbáč's avatar David Hrbáč

Salomon upgrade updated

parent 99421ac1
There's a planned upgrade of Salomon on 2018-12-04 til 2018-12-05.
There's a planned upgrade of Salomon since 2018-12-04 til 2018-12-05.
!!! Warning
This upgrade will introduce a lot of changes with respect to production and user experience.
......@@ -6,15 +6,36 @@ There's a planned upgrade of Salomon on 2018-12-04 til 2018-12-05.
!!! Hint
You might **need** to **recompile** your binaries.
Salomon operating system will be upgraded to the latest CentOS 7.5. We will be able to support latest software versions and keep the cluster security with upstream releases after the upgrade.
Salomon operating system will be upgraded to the latest CentOS 7.5. We will be able to support the latest software versions and keep the cluster security with upstream releases after the upgrade.
Major changes are:
* kernel will be upgraded to 3.10 (now 2.6.32)
* glibc will be upgraded to 2.17 (now 2.12)
* software modules must be recompiled or deleted
* kernel will be upgraded to 3.10 (2.6.32 now)
* glibc will be upgraded to 2.17 (2.12 now)
* software modules/binaries should be recompiled or deleted
## Discontinued Modules
## Faq
A new tag has been introduced. Modules tagged with **C6** might be malfunctioning. These modules might be recompiled during transition period. Keep support@it4i.cz informed on malfunctioning modules.
## Discontinued Modules
!!! Warning
Obsolete modules **O** are going to be deleted after the cluster upgrade.
```console
$ ml av intel/
-------------------------- /apps/modules/environments --------------------------
PrgEnv-intel/13.5.192 PrgEnv-intel/14.0.1 PrgEnv-intel/15.0.3 (D)
--------------------------- /apps/modules/toolchain ----------------------------
intel/default (C6) intel/2015b (C6) intel/2017c (C6)
intel/13.5.192 (O) intel/2016a (C6) intel/2017.00
intel/14.0.1 (O) intel/2016.01 intel/2018a (C6)
intel/15.2.164 (O) intel/2017a (C6) intel/2018.03 (C6)
intel/15.3.187 (O) intel/2017b (C6,D)
Where:
O: Obsolete
C6: Old CentOS6 module
D: Default Module
```
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment