Commit 447e400b authored by Easy Build's avatar Easy Build
Browse files

# new file: p/Python/Python-3.6.1.eb

#	new file:   q/QuantumESPRESSO/QuantumESPRESSO-5.4.0-foss-2015g.eb
parent ec896e76
name = 'Python'
version = '3.6.1'
homepage = 'http://python.org/'
description = "Python is a programming language that lets you work more quickly and integrate your systems more effectively."
toolchain = {'name': 'dummy', 'version': ''}
toolchainopts = {'pic': True, 'opt': True, 'optarch': True}
source_urls = ['http://www.python.org/ftp/%(namelower)s/%(version)s/']
sources = [SOURCE_TGZ]
# python needs bzip2 to build the bz2 package
dependencies = [
('bzip2', '1.0.6'),
('zlib', '1.2.8'),
('libreadline', '6.3'),
('ncurses', '5.9'),
('SQLite', '3.8.8.1'),
('Tk', '8.6.3'),
('GMP', '6.0.0a'),
('XZ', '5.2.2'),
# ('OpenSSL', '1.0.1q'), # OS dependency should be preferred if the os version is more recent then this version, it's
# nice to have an up to date openssl for security reasons
]
osdependencies = [('openssl-devel', 'libssl-dev')]
# order is important!
# package versions updated Feb 25th 2016
exts_list = [
('setuptools', '20.1.1', {
'source_urls': ['https://pypi.python.org/packages/source/s/setuptools/'],
}),
('pip', '8.0.2', {
'source_urls': ['https://pypi.python.org/packages/source/p/pip/'],
}),
('nose', '1.3.7', {
'source_urls': ['https://pypi.python.org/packages/source/n/nose/'],
}),
]
modluafooter = 'add_property("state","experimental")'
moduleclass = 'lang'
name = 'QuantumESPRESSO'
version = '5.4.0'
homepage = 'http://www.pwscf.org/'
description = """Quantum ESPRESSO is an integrated suite of computer codes
for electronic-structure calculations and materials modeling at the nanoscale.
It is based on density-functional theory, plane waves, and pseudopotentials
(both norm-conserving and ultrasoft)."""
toolchain = {'name': 'foss', 'version': '2015g'}
toolchainopts = {'usempi': True}
# major part of this list was determined from espresso/install/plugins_list
sources = [
'espresso-%(version)s.tar.gz',
'wannier90-1.2.tar.gz',
'atomic-%(version)s.tar.gz',
'neb-%(version)s.tar.gz',
'PHonon-%(version)s.tar.gz',
# must be downloaded manually from
# http://qe-forge.org/gf/project/q-e/scmsvn/?action=browse&path=%2F%2Acheckout%2A%2Ftags%2FQE-5.2.1%2Fespresso%2Farchive%2Fplumed-1.3-qe.tar.gz&revision=11758
# gets updated without changes to filename, cfr. http://qe-forge.org/pipermail/q-e-commits/2015-June/007359.html
# 'plumed-1.3-qe-r11758.tar.gz',
'pwcond-%(version)s.tar.gz',
'tddfpt-%(version)s.tar.gz',
'want-2.5.1-base.tar.gz',
'yambo-3.4.2.tgz',
'xspectra-%(version)s.tar.gz',
]
#missing_sources = [
# 'sax-2.0.3.tar.gz', # nowhere to be found
#]
#source_urls = [
# 'http://files.qe-forge.org/index.php?file=', # all sources, except espresso*.tar.gz
# 'http://qe-forge.org/gf/download/frsrelease/211/968/', # espresso-5.4.0.tar.gz
# 'http://qe-forge.org/gf/download/frsrelease/153/618/', # want-2.5.1-base.tar.gz
# 'http://qe-forge.org/gf/download/frsrelease/208/932/', # yambo-3.4.2.tgz
#]
patches = [
'QuantumESPRESSO-%(version)s_yambo-fixes.patch',
]
# gipaw excluded due to: configure: error: Cannot compile against this version of Quantum-Espresso
# add plumed and uncomment the lines in sources and checksums if the package is downloaded manually
buildopts = 'all w90 want yambo xspectra' # plumed
# parallel build tends to fail
parallel = 1
moduleclass = 'chem'
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment