Commit fac30f53 authored by easybuild's avatar easybuild
Browse files

# modified: n/ncurses/ncurses-6.0.eb

#	modified:   p/Python/Python-2.7.13.eb
#	modified:   p/Python/Python-3.6.1.eb
#	new file:   s/Szip/Szip-2.1.eb
parent 7df7d58b
...@@ -8,12 +8,14 @@ description = """The Ncurses (new curses) library is a free software emulation o ...@@ -8,12 +8,14 @@ description = """The Ncurses (new curses) library is a free software emulation o
and more. It uses Terminfo format, supports pads and color and multiple highlights and forms characters and and more. It uses Terminfo format, supports pads and color and multiple highlights and forms characters and
function-key mapping, and has all the other SYSV-curses enhancements over BSD Curses.""" function-key mapping, and has all the other SYSV-curses enhancements over BSD Curses."""
toolchain = {'name': 'dummy', 'version': 'dummy'} toolchain = {'name': 'dummy', 'version': ''}
toolchainopts = {'optarch': True, 'pic': True} toolchainopts = {'optarch': True, 'pic': True}
source_urls = [GNU_SOURCE] source_urls = [GNU_SOURCE]
sources = [SOURCE_TAR_GZ] sources = [SOURCE_TAR_GZ]
buildopts = 'CFLAGS="-O3 -fPIC"'
configopts = [ configopts = [
# default build # default build
'--with-shared --enable-overwrite', '--with-shared --enable-overwrite',
......
...@@ -15,10 +15,10 @@ sources = [SOURCE_TGZ] ...@@ -15,10 +15,10 @@ sources = [SOURCE_TGZ]
# python needs bzip2 to build the bz2 package # python needs bzip2 to build the bz2 package
dependencies = [ dependencies = [
('bzip2', '1.0.6'), ('bzip2', '1.0.6'),
('zlib', '1.2.8'), ('zlib', '1.2.11'),
('libreadline', '6.3'), ('libreadline', '6.3'),
('ncurses', '5.9'), ('ncurses', '6.0'),
('SQLite', '3.8.8.1'), ('SQLite', '3.13.0'),
# ('OpenSSL', '1.0.1k'), # OS dependency should be preferred if the os version is more recent then this version, it's # ('OpenSSL', '1.0.1k'), # OS dependency should be preferred if the os version is more recent then this version, it's
# nice to have an up to date openssl for security reasons # nice to have an up to date openssl for security reasons
] ]
......
name = 'Python' name = 'Python'
version = '3.6.1' version = '3.6.1'
versionsuffix = '-test'
homepage = 'http://python.org/' homepage = 'http://python.org/'
description = "Python is a programming language that lets you work more quickly and integrate your systems more effectively." description = "Python is a programming language that lets you work more quickly and integrate your systems more effectively."
...@@ -13,13 +14,13 @@ sources = [SOURCE_TGZ] ...@@ -13,13 +14,13 @@ sources = [SOURCE_TGZ]
# python needs bzip2 to build the bz2 package # python needs bzip2 to build the bz2 package
dependencies = [ dependencies = [
('bzip2', '1.0.6'), ('bzip2', '1.0.6'),
('zlib', '1.2.8'),
('libreadline', '6.3'), ('libreadline', '6.3'),
('ncurses', '5.9'), ('SQLite', '3.13.0'),
('SQLite', '3.8.8.1'), ('Tk', '8.6.5'),
('Tk', '8.6.3'), ('GMP', '6.1.1'),
('GMP', '6.0.0a'),
('XZ', '5.2.2'), ('XZ', '5.2.2'),
('zlib', '1.2.11'),
('ncurses', '6.0'),
# ('OpenSSL', '1.0.1q'), # OS dependency should be preferred if the os version is more recent then this version, it's # ('OpenSSL', '1.0.1q'), # OS dependency should be preferred if the os version is more recent then this version, it's
# nice to have an up to date openssl for security reasons # nice to have an up to date openssl for security reasons
] ]
......
easyblock = 'ConfigureMake'
name = 'Szip'
version = '2.1'
homepage = 'http://www.hdfgroup.org/doc_resource/SZIP/'
description = "Szip compression software, providing lossless compression of scientific data"
toolchain = {'name': 'dummy', 'version': ''}
toolchainopts = {'optarch': True, 'pic': True}
source_urls = ['http://www.hdfgroup.org/ftp/lib-external/szip/%(version)s/src']
sources = [SOURCELOWER_TAR_GZ]
configopts = "--with-pic"
sanity_check_paths = {
'files': ["lib/libsz.a", "lib/libsz.so"] +
["include/%s" % x for x in ["ricehdf.h", "szip_adpt.h", "szlib.h"]],
'dirs': [],
}
moduleclass = 'tools'
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment